CodeLobster IDE
http://codelobster.com/forum/

Debugger crashes when breakpoint set
http://codelobster.com/forum/viewtopic.php?f=3&t=23964
Page 1 of 1

Author:  PaulShipley [ Mon Oct 09, 2017 9:29 am ]
Post subject:  Debugger crashes when breakpoint set

Hi,

I am trying to use debugging with CodeLobster Pro 5.13 and XAMPP 3.2.2 (Apache 2.4.27, PHP 7.1.9) on Windows 10. When I set a breakpoint, the page times out and there are crash messages in the Windows Event Viewer. Clearing the breakpoint will allow the page to load correctly (though without debugging). Apache is running as a service.

The debugger was installed as (using Auto Detect):

Virtual Folder: C:\Apps\xampp\htdocs
Virtual Host URL: http://localhost/
Path to php.ini: C:\Apps\xampp\php
Web Server: Apache2.4
Php version: PHP_7.1.x_VC14_Thread_Safe
Port: 6000

The debugger appears to be installed (from phpinfo):
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
with Codelobster PHP Debugger v5.13.0, (C) 2005-2007, by Codelobster Software

Your assistance would be appriecated.

Thanks.

Attachments:
WindowsEvents.zip [2.43 KiB]
Downloaded 507 times
phpinfo().zip [24.43 KiB]
Downloaded 548 times

Author:  Admin [ Mon Oct 09, 2017 1:43 pm ]
Post subject:  Re: Debugger crashes when breakpoint set

Hi, PaulShipley.

Could You, please, send us your source file and the line number of your breakpoint.

Many thanks,
Codelobster Team.

Author:  PaulShipley [ Tue Oct 10, 2017 9:18 am ]
Post subject:  Re: Debugger crashes when breakpoint set

Hi Codelobster Team,

I tried to reproduce the error but the debugger is now working correctly. Perhaps the machine needed a restart after installing the debugger?

So all good now. Next time I will remember to "turn it off and on again". :oops:

Thanks.

Author:  Admin [ Tue Oct 10, 2017 3:56 pm ]
Post subject:  Re: Debugger crashes when breakpoint set

Hi.

OK - feel free to contact us if the problem occurs again.

Regards,
Codelobster Team.

Author:  sprendas [ Thu Dec 14, 2017 1:38 pm ]
Post subject:  Re: Debugger crashes when breakpoint set

Hi,

I am trying to use debugging with CodeLobster Pro 5.13 and Apache 2.4.27, PHP PHP-7.1.12 on Windows 7. When I set a breakpoint, the page times out and there are crash . Clearing the breakpoint will allow the page to load correctly (though without debugging). Apache is running as a service.

The debugger was installed as (using Auto Detect):

Attachement the information.

Attachments:
info.rar [53.73 KiB]
Downloaded 425 times
info.rar [53.73 KiB]
Downloaded 407 times

Author:  Admin [ Thu Dec 14, 2017 2:50 pm ]
Post subject:  Re: Debugger crashes when breakpoint set

Hi.

This page doesn't output anything.
So the browser shows "timeout error" if You wait too long on some breakpoint.
There isn't any crash here.

Regards,
Codelobster Team.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/