CodeLobster IDE

Free cross-platform PHP IDE (HTML, PHP, CSS, JavaScript code editor) with support Drupal, Joomla, Twig, JQuery, BackboneJS, LaravelJS, Node.js, Fhalcon, CodeIgniter, CakePHP, Laravel, Magento, MeteorJS, Phalcon, Symfony, VueJS, WordPress, Yii
It is currently Wed Dec 11, 2019 7:23 pm

All times are UTC




Post new topic Reply to topic  [ 36 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Wed Jul 04, 2018 1:59 pm 
Offline

Joined: Thu Jun 28, 2018 8:57 am
Posts: 5
Hi, many thanks for Code lobster ! I love the debugger.

I try to use the debugger on Windows 10 with PHP 7.0.2 and have a problem.

The Virtual folder is C:\Vincent\Dropbox\www\
The Virtual host URL is http://localhost/dropwww
The path to php.ini is C:\Uniserver\core\php70\php-production.ini
The Web server is let empty
The Php version is PHP_7.0.X_VC14_Thread_Safe
The port is 6000

The error message when clicking install debugger is "php.ini file not found"
I tried making a symbolic or physical link from php.ini to php-production.ini, it did not work.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Wed Jul 04, 2018 4:24 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3467
Hi.

Codelobster doesn't work with php-production.ini.
You should enter the path to php.ini file only here.

Regards,
Codelobster Team.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Wed Jul 04, 2018 5:41 pm 
Offline

Joined: Thu Jun 28, 2018 8:57 am
Posts: 5
Hi,

thanks for your interest and your reply !

I renamed php-production.ini to php.ini. (and made a hard link to php-production.ini, for the web server to use it)

It still does not work, when I click "Install debugger" or launch it, the error is :

Cannot copy C:\Program Files(x86)\CodelobsterPHP\\php_cl_dbg_7_0_VC14.dll
To
\\php_cl_dbg_7_0_VC14.dll

The path to php.ini is C:\Uniserver\core\php70 (or C:\Uniserver\core\php70\php.ini, the result is the same).


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Wed Jul 04, 2018 7:11 pm 
Offline

Joined: Thu Jun 28, 2018 8:57 am
Posts: 5
Hi,

thank you for your interest and reply.

I could rename php-production.ini to php.ini

The message is now : Cannot copy
C:\Program Files (x86)\Codelobster\CodelobsterPHP\\php_cl_dbg_7_0_VC14.dll
to
\\php_cl_dbg_7_0_VC14.dll

The specified path is not valid.

( as if the path to php.ini, C:\Uniserver\core\php70\ , was ignored )


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Mon Jul 09, 2018 9:54 am 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3467
Hi.

You have incorrect extension_dir.

It should be something like:
extension_dir="C:\xampp\php\ext"

Regards,
Codelobster Team.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Sun Sep 02, 2018 9:42 am 
Offline

Joined: Thu Jun 28, 2018 8:57 am
Posts: 5
Thank you for your reply and sorry for the delay to answer.

I made several trials but it does not work.

First I had to make a hard link from php_production.ini to php.ini for CodeLobster to accept it.

Then in php.ini, the extension_dir is defined this way :
extension_dir = "${US_ROOTF}/core/php70/extensions"

I tried :

1) to write extensively the extension_dir as you specify it
extension_dir = "C:\Uniserver\core\php70\extensions"
then... Apache won't start
the only way Apache accepts to start is to set it the unix way
extension_dir = /Uniserver/core/php70/extensions
without quotes
then... CodeLobster won't recognize it

2) to make a symbolic link from C:\Uniserver\core\phpext to C:\Uniserver\core\php70\extensions
(wondering if using four levels of directories was the problem)
then... Apache won't start

3) I did a lot of tests and it took a long time, I am sure you know what it is !

For me the better solution now is to use the debugger on another computer.

If in a further version, CodeLobster accepts server (those in PHP $_ENV) environment variables such as ${US_ROOTF} defined by Uniform server, and/or accepts forward slashes in extension dir, I will be interested !


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Mon Sep 03, 2018 12:54 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3467
Hi.

Could You, please, try CodeLobster IDE instead of CodeLobster PHP Edition.
It works with xDebug and it should work OK with Uniform server too.

Regards,
Codelobster Team.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Fri Sep 14, 2018 10:13 am 
Offline

Joined: Thu Jun 28, 2018 8:57 am
Posts: 5
Ok. Fine, it works.

By the way... just bought a license :D


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Fri Sep 14, 2018 1:17 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3467
It's great :)

We are going to release new version 1.3 with several new major features and bug-fix very soon.

Thanks,
Codelobster Team.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Sun Jan 20, 2019 9:08 am 
Offline

Joined: Tue Apr 11, 2017 10:44 am
Posts: 18
Hello, I found this thread about debugging with Codelobster, because I'm trying since some days to get the debugger working without success. I tried both the Codelobster PHP Edition e the Codelobster IDE. I decided some months ago to switch from Codelobster PHP Edition to Codelobster IDE, because I saw that Codelobster PHP Edition is discontinued, but recently I noticed that Codelobster IDE is really too slow and crashes every time that I load a php file where an Yii ActiveForm Widget is declared. So I switched back to Codelobster PHP Edition. So, the debugger of Codelobster PHP Edition shows no error, but it doesn't work, as it does not stop on breakpoints. I have Windows 10, Apache 2.4.8, PHP 7.2. May it depend on the 2 properties fields "Debug url" and "Project home url"? What shoud I write there?
Thank you


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Sun Jan 20, 2019 1:02 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3467
Hi, Anva.

1) Could You, please, send us your source Yii file
and the follwoing log-file:
C:\Users\[User Name]\AppData\Roaming\CodelobsterIDE\Codelobster.log

2) CodeLobster IDE requires xDebug installed.
Please, send us the result of the following PHP script:

<?php
print(phpinfo (INFO_ALL));
?>

Thanks,
Codelobster Team.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Sun Jan 20, 2019 3:24 pm 
Offline

Joined: Tue Apr 11, 2017 10:44 am
Posts: 18
> Could You, please, send us...
Yes, of course. Shall I append the files here in a message or send them to a specific email address?

>and the follwoing log-file:... Codelobster.log
The log file is empty, don't know why

>CodeLobster IDE requires xDebug installed
Yes, I know and I installed it, and tried all possible settings, but no success.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Sun Jan 20, 2019 3:38 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3467
Hi, Anva.

1) Yes, please, send us your source file via internal forum message or by email to support@codelobster.com

2) Please, send us your debugger setting in Codelobster and the result of the following PHP script:

<?php
print(phpinfo (INFO_ALL));
?>

Thanks,
Codelobster Team.


Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Sun Jan 20, 2019 3:51 pm 
Offline

Joined: Tue Apr 11, 2017 10:44 am
Posts: 18
Here are the files (the xdebugger is at present not installed)
Thank you


Attachments:
Files.zip [24.54 KiB]
Downloaded 574 times
Top
 Profile  
 
 Post subject: Re: Activating Debugger on Windows 10 - PHP 7.0.2
PostPosted: Mon Jan 21, 2019 8:53 am 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3467
Hi, anva.

1) We can't reproduce the crash :(
Do You work with some project?
Does Codelobster IDE crash if You open this one single file (without opening your project)?
Does Codelobster IDE crash just after file opening?
Which plug-ins are turned on?
Could You, please, send us the screenshot of the crash.

2) You havn't xDebug installed.

You should:

1. Copy php_xdebug-2.7.0beta1-7.2-vc15-nts.dll into C:\xampp\php\ext\
You can download it here:
https://xdebug.org/files/php_xdebug-2.7 ... 15-nts.dll

2. Open your php.ini file:

- comment or remove whole [CLDbg] block
- be sure, the the following section exists (and it is not commented):

[XDebug]
zend_extension = "C:\xampp\php\ext\php_xdebug-2.7.0beta1-7.2-vc15-nts.dll"
xdebug.remote_enable=on
xdebug.default_enable=on
xdebug.remote_autostart=1
xdebug.max_nesting_level=256

3. Restart apache server from XAMPP panel.
Run phpinfo() to check xdebug section.

Regards,
Codelobster Team.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 36 posts ]  Go to page 1, 2, 3  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2016 phpBB Group