CodeLobster IDE

Free cross-platform PHP IDE (HTML, PHP, CSS, JavaScript code editor) with support Drupal, Joomla, Twig, JQuery, BackboneJS, LaravelJS, Node.js, Fhalcon, CodeIgniter, CakePHP, Laravel, Magento, MeteorJS, Phalcon, Symfony, VueJS, WordPress, Yii
It is currently Fri Sep 18, 2020 2:33 pm

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: ver 3.0
PostPosted: Mon Feb 23, 2009 3:37 pm 
Offline

Joined: Thu Jul 17, 2008 3:07 pm
Posts: 75
Cannot open files from project in new version - IDE throws Unhanded exeption: Critical error: nStart < nEnd, then two times CRASH and closing itself...

P.S. not for all files... Am i to send you "bad" file or just type it's name? :D

P.P.S. the same heppening on autocomplete style="" after Enter key pressed in some files.

P.P.P.S. after i typed style="" manualy and try to save - the same errors.

P.P.P.P.S. Files didn't opened 'cause of them had contained empty style (style="") too.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 23, 2009 8:23 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3569
Hi.

Big big thanks for this bug.
We have fixed it.
Please, wait a couple of days for version 3.0.1 with several another issues also.

Regards,
Codelobster Team.


Last edited by Admin on Mon Dec 28, 2009 3:15 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 28, 2009 12:35 am 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3569
Hi.

Please, redownload new version from our site.

Regards,
Codelobster Team.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 03, 2009 4:05 pm 
Offline

Joined: Thu Jul 17, 2008 3:07 pm
Posts: 75
That's great! But... For now autocomplete of a "<script>" teg returns:
Unhanded exeption: Critical error: Can't increment Doc Iterator
As always, CRAH folowing and the IDE became closed...


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 03, 2009 8:31 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3569
Hi.

It is the bug from our old version.
When did you dowload new version?
Please, do it now.

If this bug occurs again - please, send us your code and the place where you were trying to type <script> tag.

Thanks.
Codelobster Team.


Last edited by Admin on Mon Dec 28, 2009 3:16 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Drupal, Joomla and Wordpess plug-ins in version 3.0
PostPosted: Sat Mar 07, 2009 8:04 pm 
Offline

Joined: Sat Mar 07, 2009 4:40 am
Posts: 4
It is stated in your Codelobster PHP Edition FREE Version 3.0 announcement that it includes Joomla, Wordpress and Drupal plug-ins. Are these plug-ins also free?

Another question is why don't I see any Wordpress and Joomla menu (there is Drupal menu) and also new project wizard has Drupal option but not Joomla nor Wordpress. How can I activate Joomla and Wordpress plug-ins?

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 08, 2009 12:37 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3569
Hi.

All our plug-ins are not free.
You may see current prices for it here:
http://www.codelobster.com/order.html
After purchase you should enter your serial numbers into Help -> Registration dialog for activation.

Joomla and WordPress plug-ins now has only basic functionality for autocomplete and API help. Therefore it still haven't its own menu.
After improving its functionality it will have its own menu as Drupal of course.

Regards,
Codelobster Team.


Last edited by Admin on Mon Dec 28, 2009 3:21 pm, edited 2 times in total.

Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 08, 2009 10:24 am 
Offline

Joined: Thu Jul 17, 2008 3:07 pm
Posts: 75
I'd found a regularity for the bug i was wrote above.
Not only <script> tag fails but all tags cause IDE crash with message "can't increment doc iterator" when i try to autocomplete these tegs in the begin of emty file, or after tegs block. For example:

Code:
<!-- file begin -->
<div style="padding: 40px 0px 0px 0px;">
   <strong>blah-blah-blah</strong>
</div>

<!-- if i will try to begin here new teg and use autocomplete - the ide will crash -->


or

Code:
<!-- file begin -->
<!-- if i will try to begin here new teg and use autocomplete - the ide will crash -->


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 08, 2009 12:25 pm 
Offline
Site Admin

Joined: Wed Sep 12, 2007 2:18 pm
Posts: 3569
Hi.

Big thanks.
We have repeated it and will fix it by next version.

Regards,
Codelobster Team.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2016 phpBB Group